Configuracion para quitar errores en actualización de Centos yum

Como quitar errores de paquetes duplicados en Linux Centos

si has realizado una actualización de paquetes  y te ha dado errores con yum update, la actualización, la forma de reparar este error es de la siguiente forma.

Instala el yum-utils

yum install yum-utils

a continuación realizamos un listado de todos los paquetes en conflicto o duplicados

package-cleanup --dupes

ahora vamos a quitar los paquetes en conflicto

package-cleanup --cleandupes

con esto podrás ejecutar de nuevo la actualización y comprobar si lo errores han sido eliminados.

2 comentarios

  1. No resultó, he intentado de varias formas pero no peremite:

    [root]# package-cleanup –cleandupes
    Loaded plugins: fastestmirror
    Not removing python-2.7.5-86.el7.x86_64 because it is required by 1 installed package
    Not removing python-libs-2.7.5-86.el7.x86_64 because it is required by 1 installed package
    No duplicates to remove
    Warning: Some duplicates were not removed because they are required by installed packages.
    You can try –cleandupes with –removenewestdupes, or review them with –dupes and remove manually.

    También traté con:

    [root]# package-cleanup –cleandupes –removenewestdupes Loaded plugins: fastestmirror
    Not removing python-2.7.5-88.el7.x86_64 because it is required by 2 installed packages
    Not removing python-libs-2.7.5-88.el7.x86_64 because it is required by 1 installed package
    No duplicates to remove
    Warning: Some duplicates were not removed because they are required by installed packages.
    You can try –cleandupes without –removenewestdupes, or review them with –dupes and remove manually.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *